?>
I want to do something for this site's 10th birthday in a month and ten days
GTX0 NewestRepliesHottestMy Active
NIFE UpdatesRoadmapRequests | HelpDiscuss Game Worlds


Bug fixing extravaganza post
Posted: Posted July 24th by Xhin
Edit Report Thread Views

I'm going to be chronicling all the various bugfixes the site needs here as I fix them.

There are 36 Replies
Page:
1 2 3 4 Load all posts
settingsSettings

  • Youtube videos are fixed.



  • Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

  • Fixed polls

  • Fixed the count() message that appears on posts sometimes.

  • Edited July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Clicking a link on here I got a popup that said "antwoored" with the only selection being "OK". Anything to be worried about? I screenshotted and everything.

    Posted July 24th by Fox Forever
    Edit Filter Quote Report

    https://gtx0.com/read/everything-fixed-again
    Running through this post now.

    Linguistcat opened a thread on “grouping emotions and culturally appropriate...” on Monday; but when I try to read her OP I get a blank blue screen.


    Fixed. No idea what the issue was -- best I can tell the PHP 7.3 parser itself is being buggy. Something worth investigating someday probably.

    Warning: explode() expects parameter 2 to be string, array given in /var/www/html/gtx0.com/_Read/Messages.php on line 121


    Should be fixed. Unrelated to the server move, this is a normal bug.

    Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/gtx0.com/inc/newpost.php


    This was why polls were broken. Fixed.

    : Fatal error: Uncaught Error: Unsupported operand types in /var/www/html/gtx0.com/_Write/Merit.php:9


    I fixed this issue last week.

    I noticed just now that (at the very least) Chiarizio's and my avatars are showing as blank boxes. Could you look into this, Xhin?


    @elemtilas: Can't replicate. My best guess is your browser is blocking mixed content on https sites. Try to see if you can see the avatars in another browser or device. Meanwhile I'll try to fix this issue globally where possible.

    Edited July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Clicking a link on here I got a popup that said "antwoored" with the only selection being "OK". Anything to be worried about? I screenshotted and everything.


    That was me trying to diagnose chiarizio's bug. No issues.

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    https://gtx0.com/read/site-fixed-again-again-again-except-yeah-theres-still-bugs
    Running through this post now.

    If I’m putting in a new post, and save it to go find out some detail, and come back to add it, I cannot open the thread any more.


    Can't replicate. May have fixed it with one of the other fixes. Try doing it again and give me the exact link where that's happening.

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    @Shelbai: MyCards are working again. I gave you one with a really terrible joke.

    If they're still not working for you, then you probably have the same issue as elemtilas and I'll be looking into that soon.

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    @The Fly:

    The backslash command \ for Latex disappears when you re-edit a post to correct it.


    Fixed!

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    @Shelbai: MyCards are working again. I gave you one with a really terrible joke.




    If they're still not working for you, then you probably have the same issue as elemtilas and I'll be looking into that soon.


    Oh my. It's like nothing has changed LOL. I will check in a few if it's still broken.



    Posted July 24th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    I definitely cannot input my own image, unless I am doing something wrong. (Have tried deviantArt, and imgur to try to input my own image)

    Posted July 24th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    You have to do it and say "Please GTX0 just work." at the same time.

    Posted July 24th by Moonray
    Edit Filter Quote Report

    You have to do it and say "Please GTX0 just work." at the same time.


    If only... haha. Also, long time no see.





    Posted July 24th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    Yea. What brings you back?

    I'm still here, though I barely post anything anymore. Certainly nothing of any substance :p

    Posted July 24th by Moonray
    Edit Filter Quote Report

    Saw some Xhin's posts about GTX0 on FB and got curious haha. I am currently waiting on my work permit so I have nothing but time as it is. :P

    Posted July 24th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    https://gtx0.com/read/everything-fixed-again


    Yay!

    @elemtilas: Can't replicate. My best guess is your browser is blocking mixed content on https sites. Try to see if you can see the avatars in another browser or device. Meanwhile I'll try to fix this issue globally where possible.



    Well, whatever magic you did to get the place running again seems to have fixed the issue. Some things are blocked at this end (sometimes I'll see a little "content blocked" message; but I've never had an issue here with the old conworlds.fun avatars. Because it was only those that had disappeared. I could see the native gtx0 avatars just fine.


    Posted July 24th by elemtilas
    Edit Filter Quote Report

    I definitely cannot input my own image, unless I am doing something wrong. (Have tried deviantArt, and imgur to try to input my own image)


    they probably aren't direct links -- try getting the thing that ends in .jpg or .gif or .png or whatever. Right click and select "View image" and get the link there or maybe you'll have a "copy image location" to do it directly. If you're on a phone or tablet, long-press to pull up those options.

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    I'm still here, though I barely post anything anymore. Certainly nothing of any substance :p


    It's because you're allergic to fun. :P

    I am currently waiting on my work permit so I have nothing but time as it is. :P


    What's your work permit for? Are you in a different country?

    Some things are blocked at this end (sometimes I'll see a little "content blocked" message


    @elemtilas: Where do you see those?

    but I've never had an issue here with the old conworlds.fun avatars. Because it was only those that had disappeared. I could see the native gtx0 avatars just fine.


    I think because those are being served over http and thanks to my recent server fix to get things running again, http is turning into https.

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    @elemtilas: Where do you see those?


    Where do I see what? The avatars? Over on the right side, in the column where posters' user names are. Yours I see is a dragon with "Sky's the Limit"; mine is a purple clad misterioso that chose when registering at conworlds.com back in the day.


    I think because those are being served over http and thanks to my recent server fix to get things running again, http is turning into https.


    Whatever it is, it seems to have worked!



    Posted July 24th by elemtilas
    Edit Filter Quote Report

    Where do I see what?


    The content blocked messages, where do you see those?

    Posted July 24th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Thank you Xhin. That helped XD My husband also helped me cause apparently my computer wasn't doing what it should have to get the .png link.

    And yes I moved to Canada in November. So I have been unemployed since Halloween.

    Posted July 24th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    The content blocked messages, where do you see those?



    Oh, those. They appear from time to time near the top of the screen, and then disappear. Never pair them any attention!

    Though as of now, I can't get into this thread at all:
    https://gtx0.com/read/reptigan-unions-starsystems-human-populations
    I just get a blue screen. While pretty, it's the thread I'm after!


    Edited July 24th by elemtilas
    Edit Filter Quote Report

    Funny, I can get in there just fine...

    Posted July 25th by Black Yoshi
    Edit Filter Quote Report

    Funny, I can get in there just fine...


    Odd. In your address bar, does the url have apostrophes? Or dashes? Or anything else funky?

    Edited July 25th by elemtilas
    Edit Filter Quote Report

    Nothing of the sort. Maybe it's a function of your browser? I use Firefox just so you know.

    Posted July 25th by Black Yoshi
    Edit Filter Quote Report

    Thank you Xhin. That helped XD


    Still keeping the bad joke I see. :P

    And yes I moved to Canada in November. So I have been unemployed since Halloween.


    Is it hard to get a work permit up there?

    Oh, those. They appear from time to time near the top of the screen, and then disappear. Never pair them any attention!


    Hmmm.. that's still definitely a bug. If you could get a screenshot the next time that happens, that would be very helpful.

    Though as of now, I can't get into this thread at all:


    Fixed. I just removed the problematic code entirely, so all blue screen bugs should be fixed now.




    Posted July 25th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Hey it would be r00d to get rid of it lol.

    Well the immigration process definitely hasn't been as easy as I thought it would be. Ended up getting lawyers. So really just a LOT of paperwork and waiting lol

    Posted July 25th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    So really just a LOT of paperwork and waiting lol


    Sounds like an average day at the DMV.

    Posted July 25th by Black Yoshi
    Edit Filter Quote Report

    Oh yes, lol. The struggle is real

    Posted July 25th by Shelbai
    Edit Filter Quote Report
    Shelbai
    Shell + Buy

    Dunno if it's related, but the only tab that doesn't work for me is for the Entertainment tab. Everything else works. Like I click on Video Games, it takes me to the forum. I click on Sports, it takes me to the forum. I click on Politics it takes me to the forum. I click on Entertainment and it *starts* to do it, but the forum doesn't load.

    Posted July 26th by Jet Presto
    Edit Filter Quote Report

    Same bug apparently. By far the weirdest bug of all time, so far has evaded all attempts to fix it or make sense of it.

    Posted July 26th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    I take that back, I found out what's causing it but I don't know why.

    Posted July 26th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Funny, because it loads for me just fine...I wonder if it has to do with the browser? (I'm using Firefox)

    Posted July 26th by Black Yoshi
    Edit Filter Quote Report

    It's tied to specific accounts, oddly. If I ghost Jet Presto it breaks, if I ghost you, it doesn't.

    Posted July 26th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Ah, strange

    Posted July 27th by Black Yoshi
    Edit Filter Quote Report

    @Jet Presto: Fixed.

    Well, fixed in the sense that you should be able to access that forum now, not in that I have any idea what the actual bug is or how to actually fix it.

    Posted July 27th by Xhin
    Edit Filter Quote Report
    Xhin
    Sky's the limit

    Ah, the internet sure is a strange mistress. Thanks!



    Posted July 28th by Jet Presto
    Edit Filter Quote Report
    Load next page Load rest of pages
    Reply to: Bug fixing extravaganza post
    Enter your message here

    Site Rules | Complaints Process | Give Feedback Facebook Page
    GTX0 © 2009-2019 Xhin GameTalk © 1999-2008 lives on
    You are not forgotten, Kevin, Liane, Norma, Jason, and Garrett